2.x/Updaten

Uit phpBB.nl Wiki
Ga naar: navigatie, zoeken
!! Let op: vanaf 1 januari 2009 wordt phpBB2 niet meer ondersteund door phpBB.nl en phpBB.com.

Deze pagina's dienen uitsluitend als archief.

!!


Eens in de zoveel tijd brengt de phpBB groep weer een "update" uit. We raden je aan om deze dan ook zo snel mogelijk uit te voeren. Dit zorgt ervoor: 1) dat je forum veilig blijft en 2) dat je straks niet opgezadeld zit met een stuk of 3 updates.. want je kunt in de meeste gevallen niet van bijvoorbeeld phpBB 2.0.18 naar phpBB 2.0.22 gaan. Houd dit goed in de gaten!

Dit artikel gaat over het updaten van een phpBB2 installatie naar een latere versie van phpBB2. Zie ook Upgrade phpBB2 naar phpBB3

Iets, wat geldt voor alle manieren, is het back-uppen: zorg ervoor, dat je altijd een back-up maakt van je phpBB-versie, zowel van de bestanden als van de database.

phpBB2 bijwerken

Goed. aan de slag met het bijwerken van phpBB2; als eerste moeten we een keuze maken, op welke manier we kunnen updaten. Beantwoordt voor jezelf de volgende vragen:

  • Ik heb toegang tot SSH en ben bekend met het "patchen" van software? Ja: Patch bestanden. Nee:
  • Ik heb zelf veranderingen aan mijn phpBB aangebracht, die niet verloren mogen gaan, zoals modificaties of eigen stijl-aanpassingen? Ja: Code wijzigingen. Nee:
  • Ik heb zelf geen veranderingen aan mijn phpBB aangebracht: Gewijzigde bestanden

Download op phpBB.nl de laatste versie: http://www.phpbb.nl/downloads

Patchbestanden

Mocht je over de kennis hiervan beschikken, dan is verder geen uitleg nodig; je vindt de eventuele (Engelse) informatie bijgesloten in de download.

Code wijzigingen

  • Je hebt zelf dus wijzigingen aangebracht, die niet verloren mogen gaan. In dat geval zit er niks anders op dan zelf de code van phpBB aan te passen. Voor diegene, die bekend is met het installeren van modificaties, zal dit wel meevallen.
  • In de download vindt je een map (install) en een text-bestand. Het eerste, wat je doet, is je forum Uitschakelen; dit doe je in je Beheerderspaneel.
  • Vervolgens upload je de map install/ (met inhoud) naar je phpBB root (dus dezelfde map, als waar je config.php vindt); zodra die online staat, surf je naar het bestand in de install/ map: http://www.mijndomein.nl/install/update_to_latest.php. Je krijgt dan een scherm te zien, dat hij phpBB aan het updaten is; zodra dit is voltooid, is je phpBB in de database bijgewerkt en moet je de map install/ uit je root verwijderen.
  • Daarna ga je de code-wijzigingen toepassen; je zult de instructies op moeten volgen, die in het text-bestand staan uitgelegd. Onbekend met de instructies? Zie dan Modificatie installeren. Als dit is gelukt, upload je alle bestanden naar je forum. En is je forum helemaal bijgewerkt.
  • Open nu het forum weer en kijk, of alle wijzigingen correct zijn doorgevoerd.
  • Mocht je een foutmelding tegenkomen, controleer dan aan de hand van het text-bestand, of je de fout kan achterhalen en of je mogelijk ergens een foutje hebt gemaakt.
  • Eventueel kun je op het forum nog kijken, of er bij de Nederlandse taal nog wijzigingen zijn aangebracht.

Gewijzigde bestanden

  • Je hebt geluk: bijwerken is voor jou een eitje. ;-)
  • In de download vindt je 2.0.x_to_2.0.x.zip; die pak je nog eens uit en de inhoud van dat archief upload je naar je forum via ftp en overschrijf je daarmee een aantal bestaande bestanden.
  • Als je met je webbrowser naar je forum surft, zul je merken, dat je de melding krijgt, dat "/install" en "/contrib" verwijderd moeten worden; voordat je dat gaat doen, moet je eerst de database updaten! Je surft met je webbrowser naar het database update bestand in de /install-map: http://www.mijndomein.nl/install/update_to_latest.php; dit zou ook kunnen zijn: http://forum.mijndomein.nl/install/update_to_latest.php. Je krijgt dan een scherm te zien, dat hij phpBB aan het updaten is; zodra dit is voltooid, is je phpBB in de database bijgewerkt en moet je via ftp de mappen "/install" en "/contrib" uit je forum-root verwijderen.
  • Eventueel kun je op dit forum nog kijken, of er in de Nederlandse taalbestanden wijzigingen zijn aangebracht.

Veel voorkomende vragen

V: In mijn beheerderspaneel staat nog de oude versie.
A: Je bent vergeten de database update uit te voeren.

V: Er staat, dat ik de map contrib/ en install/ moet verwijderen.
A: Kijk in de root van je phpBB forum, of je die mappen aantreft en verwijder ze dan.

V: Ik kan niet meer inloggen?
A: Zorg ervoor, dat al je configuratie-instellingen goed zijn, zie hiervoor: Auto Cookies

V: Ik mis "Visuele Confirmatie" in mijn beheerderspaneel?
A: Heb je de wijzigingen ook daadwerkelijk toegepast op alle stijlen?

V: In de Nederlandse taal ontbreken teksten?
A: Zorg er ook voor, dat je de laatste Nederlandse taal versie hebt gedownload.

V: Update_to_latest.php geeft een foutmelding?
A: Zorg ervoor, dat je hem in de install/ map hebt geplaatst; van daaruit kun je hem updaten.

Zie ook Upgrade phpBB2 naar phpBB3